(Untitled)

Ficha Proveedor

Utilice la ficha Proveedor para seleccionar el proveedor de OLE DB adecuado para el tipo de datos a los que desea tener acceso. No todas las aplicaciones le permiten especificar un proveedor o modificar la selección actual; esta ficha se muestra únicamente si la aplicación permite modificar la selección del proveedor de OLE DB. Puede guardar un vínculo de datos en la propia aplicación o como un archivo independiente. Para obtener más información sobre la creación de vínculos de datos, consulte "Crear un vínculo de datos" en MDAC SDK.

Opción | Descripción
Proveedores de OLE DB | Enumera todos los proveedores de OLE DB que se detectaron en su equipo. Para obtener más información sobre proveedores, consulte "Introducción a los proveedores de Microsoft OLE DB" en MDAC SDK.
Siguiente | Abre la ficha Conexión del proveedor de OLE DB seleccionado.

Nota Puede ir directamente a la ficha Conexión si hace doble clic en el proveedor que desee. Para obtener más información sobre Vínculos de datos, consulte la Referencia de la API de vínculos de datos.


Ficha Avanzadas

Utilice la ficha Avanzadas para ver y establecer otras propiedades de inicialización para los datos.

La ficha Avanzadas del cuadro de diálogo Propiedades de vínculo de datos es específica del proveedor y muestra únicamente las propiedades de inicio requeridas por el proveedor de OLE DB seleccionado. Si desea obtener más información acerca de las propiedades de inicialización avanzadas, consulte la documentación suministrada por cada proveedor de OLE DB.

La tabla siguiente describe la mayoría de las opciones de inicialización.

Opción | Descripción
Nivel de representación El nivel de representación que puede utilizar el servidor al personificar al cliente. Esta propiedad es aplicable únicamente a conexiones de red distintas de las conexiones de Llamada de procedimiento remoto (RPC); estos niveles de representación son similares a los proporcionados por RPC. Los valores de esta propiedad se corresponden directamente con los niveles de representación que se pueden especificar para las conexiones RPC, pero se pueden aplicar a conexiones distintas de las RPC autenticadas. Seleccione uno de los niveles siguientes:
  • Anónimo: el cliente es anónimo para el servidor. El proceso del servidor no puede obtener información de identificación acerca del cliente y no puede representarlo.

  • Delegar: el proceso puede representar el contexto de seguridad del cliente mientras actúa en su nombre. El proceso del servidor puede realizar también llamadas salientes a otros servidores actuando en nombre del cliente.

  • Identificar: el servidor puede obtener la identidad del cliente. El servidor puede representar al cliente para comprobación ACL pero no puede tener acceso a los objetos del sistema como el cliente.

  • Personificar: el proceso del servidor puede personificar el contexto de seguridad del cliente actuando en su lugar. Esta información se obtiene al establecer la conexión, no en cada llamada.
Nivel de protección El nivel de protección de los datos enviados entre cliente y servidor. Esta propiedad es aplicable únicamente a conexiones de red distintas de las conexiones RPC; estos niveles de protección son similares a los proporcionados por RPC. Los valores de esta propiedad se corresponden directamente con los niveles de protección que se pueden especificar para las conexiones RPC autenticadas, pero se pueden aplicar a conexiones distintas de las RPC autenticadas. Seleccione uno de los niveles siguientes:
  • Llamada: autentica el origen de datos al principio de cada petición del cliente al servidor.

  • Conexión: autentica únicamente cuando el cliente establece la conexión con el servidor.

  • Ninguno: no realiza autenticación de los datos enviados al servidor.

  • Pkt: autentica que todos los datos son recibidos por el cliente.

  • Integridad Pkt: autentifica que todos los datos son recibidos por el cliente y que no ha habido ningún cambio en el tránsito.

  • Privacidad Pkt: autentica que todos los datos son recibidos por el cliente y que no ha habido ningún cambio en el tránsito, y protege la privacidad de los datos cifrándolos.
Tiempo de espera de conexión | Especifica el tiempo (en segundos) que el proveedor de OLE DB espera a que finalice la inicialización. Si transcurre el tiempo de espera sin que haya finalizado la inicialización, se devuelve un error y no se establece la conexión.
Permisos de acceso Seleccione uno o más de los permisos siguientes:
  • Lectura: sólo lectura.

  • Lectura-escritura: lectura y escritura.

  • No denegar en modo compartido: no se puede denegar el acceso de lectura ni de escritura.

  • Lectura denegada en modo compartido: impide la apertura en modo lectura.

  • Escritura denegada en modo compartido: impide la apertura en modo escritura.

  • Exclusivo en modo compartido: impide la apertura en modo lectura o escritura.

  • Escritura: sólo escritura.

Nota Para obtener más información sobre la inicialización de Vínculos de datos, consulte la Referencia de la API de vínculos de datos.


Ficha Todas

Utilice la ficha Todas para ver y modificar todas las propiedades de inicialización de OLE DB disponibles para su proveedor de OLE DB. Las propiedades pueden variar según el proveedor de OLE DB que esté utilizando. Si desea obtener más información acerca de las propiedades de inicialización avanzadas, consulte la documentación suministrada por cada proveedor de OLE DB.

Opción | Descripción
Lista de propiedades de inicialización | Enumera todas las propiedades y sus valores actuales.
Modificar valor | Abre el cuadro de diálogo Modificar valor de propiedad correspondiente a la propiedad seleccionada.

Nota Puede abrir el cuadro de diálogo Modificar valor de propiedad si hace clic en la propiedad seleccionada. Para obtener más información sobre la inicialización de Vínculos de datos, consulte la Referencia de la API de vínculos de datos.


Ficha Conexión

Utilice la ficha Conexión para especificar cómo conectar con los datos mediante un proveedor OLE DB.

La ficha Conexión del cuadro de diálogo Propiedades de vínculo de datos es específica del proveedor y muestra únicamente las propiedades de conexión requeridas por el proveedor de OLE DB seleccionado. Las propiedades de conexión le permiten especificar la ubicación de los datos y el método de conexión. Para obtener más información, consulte la documentación de cada proveedor de OLE DB.

La tabla siguiente describe la mayoría de las opciones de conexión.

Opción | Descripción
Origen de datos | Escriba el nombre del origen de datos al que desea tener acceso (generalmente es un nombre de servidor).
Ubicación | Escriba la ubicación del origen de datos al que desea tener acceso (generalmente es el nombre de una base de datos).
Utilizar seguridad integrada de Windows NT | Haga clic para utilizar un servicio de autenticación a fin de identificarse. Para utilizar esta característica, su proveedor de OLE DB debe admitir un servicio de autenticación. El proveedor de OLE DB para SQL Server constituye un ejemplo. También debe tener permisos en el origen de datos para utilizar el servicio de autenticación.
Utilizar un nombre de usuario y contraseña específicos | Seleccione esta opción para utilizar un nombre de usuario y una contraseña para autenticar la información de inicio de sesión en el origen de datos.
Nombre de usuario | Escriba el identificador de usuario que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña | Escriba la contraseña que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña en blanco | Permite al proveedor especificado devolver una contraseña en blanco en la cadena de conexión.
Permitir guardar contraseña | Permite guardar la contraseña con la cadena de conexión. Si la contraseña se incluye o no en la cadena de conexión depende del funcionamiento de la aplicación que llama. Nota Si se guarda, la contraseña es devuelta y guardada sin máscara ni cifrado.
Escriba el catálogo inicial que se va a utilizar | Escriba el catálogo al que desea tener acceso durante la conexión.
Probar conexión | Haga clic para intentar una conexión al origen de datos especificado. Si hay un error en la conexión, asegúrese de que la configuración es correcta. Por ejemplo, un error ortográfico o la distinción entre mayúsculas y minúsculas podrían provocar un error en la conexión.

Nota Para obtener más información sobre la conexión de Vínculos de datos, consulte la Referencia de la API de vínculos de datos.


Ficha Conexión para Jet

Utilice la ficha Conexión para especificar cómo conectar a los datos de Microsoft Access.

La ficha Conexión depende del proveedor y sólo muestra las propiedades de conexión que necesita el proveedor de OLE DB para Microsoft Jet.

Opción | Descripción
Nombre de base de datos | Escriba el nombre del archivo de Microsoft Access (.mdb) al que desea tener acceso. Para buscar el archivo, haga clic en el botón Examinar.
Nombre de usuario | Escriba el identificador de usuario que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña | Escriba la contraseña que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña en blanco | Permite al proveedor especificado devolver una contraseña en blanco en la cadena de conexión.
Permitir guardar contraseña | Permite guardar la contraseña con la cadena de conexión. Si la contraseña se incluye o no en la cadena de conexión depende del funcionamiento de la aplicación que llama. Nota Si se guarda, la contraseña es devuelta y guardada sin máscara ni cifrado.
Probar conexión | Haga clic para intentar una conexión al origen de datos especificado. Si hay un error en la conexión, asegúrese de que la configuración es correcta. Por ejemplo, un error ortográfico o la distinción entre mayúsculas y minúsculas podrían provocar un error en la conexión.

Nota Para obtener más información sobre la conexión de Vínculos de datos, consulte la Referencia de la API de vínculos de datos.


Ficha Conexión para ODBC

Utilice la ficha Conexión para especificar cómo conectar a los datos ODBC.

La ficha Conexión depende del proveedor y sólo muestra las propiedades de conexión que necesita el proveedor de Microsoft OLE DB para ODBC.

Opción | Descripción
Utilizar nombre de origen de datos | Seleccione de la lista o escriba el nombre del origen de datos (DSN) ODBC al que desea tener acceso. Puede agregar más orígenes mediante el Administrador de orígenes de datos ODBC. Haga clic en Actualizar para actualizar la lista.
Utilizar cadena de conexión | Permite escribir o crear una cadena de conexión ODBC en vez de utilizar un DSN existente.
Generar Abre el cuadro de diálogo Seleccionar origen de datos. Cuando selecciona un origen de datos, la cadena de conexión del origen de datos aparece en la ficha Conexión del cuadro de diálogo Propiedades de vínculo de datos.

Si selecciona un DSN de archivo, la cadena de conexión ODBC resultante no está basada en un DSN. La cadena de conexión ODBC se guarda en el archivo de vínculo de datos (.udl) y no se basa en el DSN de archivo seleccionado.

Si selecciona un DSN de equipo, la cadena de conexión ODBC resultante es de tipo DSN. La cadena de conexión ODBC utiliza como referencia el DSN de equipo seleccionado. Si un usuario de un sistema distinto intenta tener acceso al archivo de vínculo de datos (.udl), el usuario debe tener también el DSN de equipo instalado.
Nombre de usuario | Escriba el identificador de usuario que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña | Escriba la contraseña que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña en blanco | Permite al proveedor especificado devolver una contraseña en blanco en la cadena de conexión.
Permitir guardar contraseña Permite guardar la contraseña con la cadena de conexión. Si la contraseña se incluye o no en la cadena de conexión depende del funcionamiento de la aplicación que llama.

Nota Si se guarda, la contraseña es devuelta y guardada sin máscara ni cifrado.
Escriba el catálogo inicial que se va a utilizar | Escriba el nombre del catálogo (o base de datos) o selecciónelo en la lista desplegable.
Probar conexión | Haga clic para intentar una conexión al origen de datos especificado. Si hay un error en la conexión, asegúrese de que la configuración es correcta. Por ejemplo, un error ortográfico o la distinción entre mayúsculas y minúsculas podrían provocar un error en la conexión.

Nota Para obtener más información sobre la conexión de Vínculos de datos, consulte la Referencia de la API de vínculos de datos.


Ficha Conexión para Oracle

Utilice la ficha Conexión para especificar cómo conectar a datos Oracle.

La ficha Conexión depende del proveedor y sólo muestra las propiedades de conexión que necesita el proveedor de Microsoft OLE DB para Oracle.

Opción | Descripción
Nombre de servidor | Escriba el servidor donde se encuentra la base de datos a la que desea tener acceso.
Nombre de usuario | Escriba el identificador de usuario que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña | Escriba la contraseña que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña en blanco | Permite al proveedor especificado devolver una contraseña en blanco en la cadena de conexión.
Permitir guardar contraseña | Permite guardar la contraseña con la cadena de conexión. Si la contraseña se incluye o no en la cadena de conexión depende del funcionamiento de la aplicación que llama. Nota Si se guarda, la contraseña es devuelta y guardada sin máscara ni cifrado.
Probar conexión | Haga clic para intentar una conexión al origen de datos especificado. Si hay un error en la conexión, asegúrese de que la configuración es correcta. Por ejemplo, un error ortográfico o la distinción entre mayúsculas y minúsculas podrían provocar un error en la conexión.

Nota Para obtener más información sobre la conexión de Vínculos de datos, consulte la Referencia de la API de vínculos de datos.


Ficha Conexión para SQL Server

Utilice la ficha Conexión para especificar cómo conectar a los datos de Microsoft SQL Server.

La ficha Conexión depende del proveedor y sólo muestra las propiedades de conexión que necesita el proveedor de OLE DB para Microsoft SQL Server.

Opción | Descripción
Nombre de servidor | Seleccione un nombre de servidor de la lista desplegable o escriba la ubicación del servidor donde se encuentra la base de datos a la que desea obtener acceso. La selección de una base de datos en el servidor es una acción independiente. Haga clic en Actualizar para actualizar la lista.
Utilizar seguridad integrada de Windows NT | Haga clic para especificar que el proveedor solicita una conexión segura (o de confianza) con un servidor SQL que se ejecuta en Microsoft Windows NT. Al seleccionar esta opción, SQL Server utiliza seguridad integrada de inicio de sesión para establecer las conexiones que utilizan este origen de datos sin tener en cuenta el tipo de seguridad de inicio de sesión del servidor. Se ignora cualquier otro tipo de Id. o contraseña de inicio de sesión. El administrador del sistema SQL Server debe haber asociado el Id. de red de Microsoft Windows con un Id. de inicio de sesión de SQL Server.
Utilizar un nombre de usuario y contraseña específicos | Seleccione esta opción para utilizar un nombre de usuario y una contraseña para autenticar la información de inicio de sesión en el origen de datos.
Nombre de usuario | Escriba el identificador de usuario que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña | Escriba la contraseña que se va a utilizar para la autenticación cuando inicie sesión en el origen de datos.
Contraseña en blanco | Permite al proveedor especificado devolver una contraseña en blanco en la cadena de conexión.
Permitir guardar contraseña Permite guardar la contraseña con la cadena de conexión. Si la contraseña se incluye o no en la cadena de conexión depende del funcionamiento de la aplicación que llama.

Nota Si se guarda, la contraseña es devuelta y guardada sin máscara ni cifrado.
Seleccionar base de datos Use uno de los métodos siguientes:
  • Escriba el nombre de la base de datos a la que desea tener acceso.

  • Para SQL Server 7.0, adjunte un archivo de base de datos SQL como nombre de base de datos. Escriba el nombre de base de datos que se va a utilizar para el archivo de base de datos SQL adjunto.

  • Para SQL Server versión 6.5 y anteriores, escriba el nombre del archivo de base de datos que se va a adjuntar. Después, escriba el nombre del archivo único de base de datos. Para buscar el archivo, haga clic en el botón Examinar.
Probar conexión | Haga clic para intentar una conexión al origen de datos especificado. Si hay un error en la conexión, asegúrese de que la configuración es correcta. Por ejemplo, un error ortográfico o la distinción entre mayúsculas y minúsculas podrían provocar un error en la conexión.

Nota Para obtener más información sobre la conexión de Vínculos de datos, consulte la Referencia de la API de vínculos de datos.


Referencia de la API de vínculos de datos

Se encuentra disponible más información acerca de la API de vínculos de datos en msdn.microsoft.com. (Abra MSDN Library Online y después Platform SDK para buscar MDAC SDK, que contiene una sección llamada Referencia de la API de vínculos de datos (Data Link API Reference).)


Cuadro de diálogo Modificar valor de propiedad

Utilice el cuadro de diálogo Modificar valor de propiedad para modificar la propiedad de inicialización OLE DB seleccionada en la ficha Todas. Las propiedades pueden variar según el proveedor de OLE DB.

Nota Si desea obtener más información acerca de las propiedades específicas del proveedor, consulte la documentación suministrada con cada proveedor de OLE DB específico.

Opción | Descripción
Descripción de propiedad | Muestra la descripción de la propiedad seleccionada.
Valor de propiedad | Seleccione un valor válido.
Restablecer valor | Establece como valor de la propiedad seleccionada el valor predeterminado del proveedor OLE DB.